Taskcare Help Center

            Which Version of Android & iOS is required to run TaskCare?

            The following are the minimum required versions needed to run TaskCare in your Android & iOS device.

            For Android: Any android device with version 5.0 and above is supported.

            For iOS: Requires iOS 9.0 or later. Compatible with iPhone, iPad and iPod touch.
            Updated: 25 Feb 2019 03:25 PM
            Helpful?  
            Help us to make this article better
            0 0